Vultaire Snap Proxy Overrides

  • By Paul Goins
Channel Version Revision Published Runs on
latest/edge 2 2 16 Jun 2021
Ubuntu 20.04 Ubuntu 18.04
juju deploy vultaire-snap-proxy-overrides --channel edge
Show information
You will need Juju 2.9 to be able to run this command. Learn how to upgrade to Juju 2.9.

Platform:

Ubuntu
18.04 20.04

About

A charm for helping with monthly updates of snap-proxy revision pinnings. Read more


Relevant links


Discuss this charm

Share your thoughts on this charm with the community on discourse.

Join the discussion

snap-proxy-overrides

Description

TODO: Describe your charm in a few paragraphs of Markdown

Usage

TODO: Provide high-level usage, such as required config or relations

Developing

Create and activate a virtualenv with the development requirements:

virtualenv -p python3 venv
source venv/bin/activate
pip install -r requirements-dev.txt

Testing

The Python operator framework includes a very nice harness for testing operator behaviour without full deployment. Just run_tests:

./run_tests