Neutron Api Plumgrid

juju deploy neutron-api-plumgrid
Show information
You will need Juju 2.9 to be able to run this command. Learn how to upgrade to Juju 2.9.
Channel Version Revision Published Base
latest/stable 4 4 11 Nov 2020
14.04
latest/edge 1 1 11 Nov 2020
14.04

Platform:

14.04
  • connector-type | string

    Default: distributed

    Type of connector to be used. Supported types are 'distributed' and 'service'

  • enable-metadata | boolean

    Default: True

    Set as True to enable metadata support

  • hardware-vendor-name | string

    Default: vendor_name

    Name of the supported hardware vendor

  • install_keys | string

    Provide the respective keys of the install sources

  • install_sources | string

    Default: ppa:plumgrid-team/stable

    Provide the install source from where to install the PLUMgrid debs

  • manage-neutron-plugin-legacy-mode | boolean

    Default: True

    If True neutron-api charm will install neutron packages for the plugin configured. Also needs to be set in neutron-api charm

  • networking-plumgrid-version | string

    Provide the version of networking-plumgrid package that needs to be installed

  • pip-proxy | string

    Default: None

    Proxy address to install python modules behind a proxy

  • plumgrid-build | string

    Default: latest

    Provide the build version of PLUMgrid packages that needs to be installed

  • project-domain-name | string

    Default: Default

    Keystone project domain name

  • switch-password | string

    Default: plumgrid

    Password of the L2 gateway

  • switch-username | string

    Default: plumgrid

    Username of the L2 gateway

  • user-domain-name | string

    Default: Default

    Keystone user domain name